import re
regex = re.compile(r"\"([^\"]+)\"|\s+")
test_str = "\"reference is\" to ser?? test*"
subst = "\\1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)