package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`users\/(.*?)\&`)
var str = `https://www.myapi.com/player/?url=https%3A//myapi.com/users/11468859&color=788b78&auto_play=false&show_artwork=false`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}