re = /users\/(.*?)\&/
str = 'https://www.myapi.com/player/?url=https%3A//myapi.com/users/11468859&color=788b78&auto_play=false&show_artwork=false'
# Print the match result
str.match(re) do |match|
puts match.to_s
end