using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{[\w\s-\\\/_=*%\'\""]+\}(.+?)|(.+?)\{[\w\s-\\\/_=*%\'\""]+\}";
string input = @"{1}2{3}4{5}6{7}
2{3}4{5}6{7}
{1}2{3}4{5}6
{1}2{3}4{5}{6{7}
{1}2{3}4{5}}{{{6{7}
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}