import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[\\w\\s-\\\\\\/_=*%\\'\\\"]+\\}(.+?)|(.+?)\\{[\\w\\s-\\\\\\/_=*%\\'\\\"]+\\}";
final String string = "{1}2{3}4{5}6{7}\n"
+ "2{3}4{5}6{7}\n"
+ "{1}2{3}4{5}6\n"
+ "{1}2{3}4{5}{6{7}\n"
+ "{1}2{3}4{5}}{{{6{7}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}