$re = '/\{[\w\s-\\\\\/_=*%\'\"]+\}(.+?)|(.+?)\{[\w\s-\\\\\/_=*%\'\"]+\}/i';
$str = '{1}2{3}4{5}6{7}
2{3}4{5}6{7}
{1}2{3}4{5}6
{1}2{3}4{5}{6{7}
{1}2{3}4{5}}{{{6{7}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);