$re = '/(?:\G(?!^)|[\w-]{2}(?=[\w-]*@))\K[^@]/i';
$str = 'example@gmail.com';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;