re = /(?:\G(?!^)|[\w-]{2}(?=[\w-]*@))\K[^@]/i
str = 'example@gmail.com'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result