#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a.*?</a>|\b(estoppel)\b"
Local $sString = "This is a estoppel page" & @CRLF & _
"<a href='https://sample.com/the-estoppel/' class="exclude-link" target="_blank" rel="noopener">Chapter 1 – The effect of promissory estoppel.</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")