// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<a.*?</a>|\b(estoppel)\b").unwrap();
let string = "This is a estoppel page
<a href='https://sample.com/the-estoppel/' class=\"exclude-link\" target=\"_blank\" rel=\"noopener\">Chapter 1 – The effect of promissory estoppel.</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}