re = /<a.*?<\/a>|\b(estoppel)\b/m
str = 'This is a estoppel page
<a href=\'https://sample.com/the-estoppel/\' class="exclude-link" target="_blank" rel="noopener">Chapter 1 – The effect of promissory estoppel.</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end