#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^>PATTERN)|(?:^>[\s\S]*?)(?=\v?^>|\z)"
Local $sString = ">PATTERN" & @CRLF & _
"1 " & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"" & @CRLF & _
">PATTERN" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"c" & @CRLF & _
"" & @CRLF & _
">PATTERN" & @CRLF & _
"1 " & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"" & @CRLF & _
">PATTERN" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"c" & @CRLF & _
"" & @CRLF & _
">asdf" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"" & @CRLF & _
">asdf" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")