const regex = /(?:^>PATTERN)|(?:^>[\s\S]*?)(?=\v?^>|\z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^>PATTERN)|(?:^>[\\s\\S]*?)(?=\\v?^>|\\z)', 'gm')
const str = `>PATTERN
1
2
3
>PATTERN
a
b
c
>PATTERN
1
2
3
>PATTERN
a
b
c
>asdf
1
2
3
>asdf
a
b
c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}