import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^>PATTERN)|(?:^>[\\s\\S]*?)(?=\\v?^>|\\z)";
final String string = ">PATTERN\n"
+ "1 \n"
+ "2\n"
+ "3\n\n"
+ ">PATTERN\n"
+ "a\n"
+ "b\n"
+ "c\n\n"
+ ">PATTERN\n"
+ "1 \n"
+ "2\n"
+ "3\n\n"
+ ">PATTERN\n"
+ "a\n"
+ "b\n"
+ "c\n\n"
+ ">asdf\n"
+ "1\n"
+ "2\n"
+ "3\n\n"
+ ">asdf\n"
+ "a\n"
+ "b\n"
+ "c";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}