#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=url=tcp://)[1-9][0-9]?\.tcp\.(?:ap|au|eu|in|jp|sa|us)\.ngrok\.io:[1-9][0-9]{4}\b"
Local $sString = "t=2023-07-05T16:17:15+0300 lvl=info msg="no configuration paths supplied"" & @CRLF & _
"t=2023-07-05T16:17:15+0300 lvl=info msg="using configuration at default config path" path=C:\\Users\\***\\AppData\\Local/ngrok/ngrok.yml" & @CRLF & _
"t=2023-07-05T16:17:15+0300 lvl=info msg="open config file" path=C:\\Users\\***\\AppData\\Local\\ngrok\\ngrok.yml err=nil" & @CRLF & _
"t=2023-07-05T16:17:15+0300 lvl=info msg="starting web service" obj=web addr=127.0.0.1:4040 allow_hosts=[]" & @CRLF & _
"t=2023-07-05T16:17:15+0300 lvl=info msg="tunnel session started" obj=tunnels.session" & @CRLF & _
"t=2023-07-05T16:17:15+0300 lvl=info msg="client session established" obj=csess" & @CRLF & _
"t=2023-07-05T16:17:15+0300 lvl=info msg="started tunnel" obj=tunnels name=command_line addr=//localhost:8865 url=tcp://4.tcp.eu.ngrok.io:10355" & @CRLF & _
"t=2023-07-05T16:17:16+0300 lvl=info msg="update available" obj=updater"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")