import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=url=tcp://)[1-9][0-9]?\\.tcp\\.(?:ap|au|eu|in|jp|sa|us)\\.ngrok\\.io:[1-9][0-9]{4}\\b";
final String string = "t=2023-07-05T16:17:15+0300 lvl=info msg=\"no configuration paths supplied\"\n"
+ "t=2023-07-05T16:17:15+0300 lvl=info msg=\"using configuration at default config path\" path=C:\\\\Users\\\\***\\\\AppData\\\\Local/ngrok/ngrok.yml\n"
+ "t=2023-07-05T16:17:15+0300 lvl=info msg=\"open config file\" path=C:\\\\Users\\\\***\\\\AppData\\\\Local\\\\ngrok\\\\ngrok.yml err=nil\n"
+ "t=2023-07-05T16:17:15+0300 lvl=info msg=\"starting web service\" obj=web addr=127.0.0.1:4040 allow_hosts=[]\n"
+ "t=2023-07-05T16:17:15+0300 lvl=info msg=\"tunnel session started\" obj=tunnels.session\n"
+ "t=2023-07-05T16:17:15+0300 lvl=info msg=\"client session established\" obj=csess\n"
+ "t=2023-07-05T16:17:15+0300 lvl=info msg=\"started tunnel\" obj=tunnels name=command_line addr=//localhost:8865 url=tcp://4.tcp.eu.ngrok.io:10355\n"
+ "t=2023-07-05T16:17:16+0300 lvl=info msg=\"update available\" obj=updater";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}