# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=url=tcp://)[1-9][0-9]?\.tcp\.(?:ap|au|eu|in|jp|sa|us)\.ngrok\.io:[1-9][0-9]{4}\b"
test_str = ("t=2023-07-05T16:17:15+0300 lvl=info msg=\"no configuration paths supplied\"\n"
"t=2023-07-05T16:17:15+0300 lvl=info msg=\"using configuration at default config path\" path=C:\\\\Users\\\\***\\\\AppData\\\\Local/ngrok/ngrok.yml\n"
"t=2023-07-05T16:17:15+0300 lvl=info msg=\"open config file\" path=C:\\\\Users\\\\***\\\\AppData\\\\Local\\\\ngrok\\\\ngrok.yml err=nil\n"
"t=2023-07-05T16:17:15+0300 lvl=info msg=\"starting web service\" obj=web addr=127.0.0.1:4040 allow_hosts=[]\n"
"t=2023-07-05T16:17:15+0300 lvl=info msg=\"tunnel session started\" obj=tunnels.session\n"
"t=2023-07-05T16:17:15+0300 lvl=info msg=\"client session established\" obj=csess\n"
"t=2023-07-05T16:17:15+0300 lvl=info msg=\"started tunnel\" obj=tunnels name=command_line addr=//localhost:8865 url=tcp://4.tcp.eu.ngrok.io:10355\n"
"t=2023-07-05T16:17:16+0300 lvl=info msg=\"update available\" obj=updater")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.