#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!paragraph_b)\w+ \w+\((?:\n(?!^\w+ \w+\().*)*\)(?=\s*^paragraph_b)"
Local $sString = "some random texts (100+ lines)" & @CRLF & _
"bbb" & @CRLF & _
"..." & @CRLF & _
"ttt" & @CRLF & _
"some random texts" & @CRLF & _
"ccc" & @CRLF & _
"..." & @CRLF & _
"fff " & @CRLF & _
"paragraph_a A_story(" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
"some random texts adfsasdsd" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"paragraph_a A_story(" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
"some random texts adfsasdsd" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"paragraph_a A_story(" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
"some random texts adfsasdsd" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"paragraph_b different_story(" & @CRLF & _
"..." & @CRLF & _
"some random texts" & @CRLF & _
"..." & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"paragraph_b different_story(" & @CRLF & _
"..." & @CRLF & _
"some random texts" & @CRLF & _
"..." & @CRLF & _
")"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)