# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!paragraph_b)\w+ \w+\((?:\n(?!^\w+ \w+\().*)*\)(?=\s*^paragraph_b)"
test_str = ("some random texts (100+ lines)\n"
"bbb\n"
"...\n"
"ttt\n"
"some random texts\n"
"ccc\n"
"...\n"
"fff \n"
"paragraph_a A_story(\n\n"
"...\n"
"some random texts adfsasdsd\n\n"
"...\n"
")\n\n"
"paragraph_a A_story(\n\n"
"...\n"
"some random texts adfsasdsd\n\n"
"...\n"
")\n\n"
"paragraph_a A_story(\n\n"
"...\n"
"some random texts adfsasdsd\n\n"
"...\n"
")\n\n"
"paragraph_b different_story(\n"
"...\n"
"some random texts\n"
"...\n"
")\n\n"
"paragraph_b different_story(\n"
"...\n"
"some random texts\n"
"...\n"
")")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.