$re = '/^(?!paragraph_b)\w+ \w+\((?:\n(?!^\w+ \w+\().*)*\)(?=\s*^paragraph_b)/m';
$str = 'some random texts (100+ lines)
bbb
...
ttt
some random texts
ccc
...
fff
paragraph_a A_story(
...
some random texts adfsasdsd
...
)
paragraph_a A_story(
...
some random texts adfsasdsd
...
)
paragraph_a A_story(
...
some random texts adfsasdsd
...
)
paragraph_b different_story(
...
some random texts
...
)
paragraph_b different_story(
...
some random texts
...
)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;