using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/)(?=\*)(?:\*)((?:\1|[\s\S])*?)(?:\*)\1|(?=(\/\/)(.*))|<!--((?:(?!-->)[\s\S])*)-->";
string input = @"/*
something
*/
/* something */
/*
* // something
*
*/
/*/something/*/
// teste
<!-- HTML Comment //-->
or
<!-- HTML Comment -->
<!-- HTML Comment
-->
<!--
HTML Comment
-->
// test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}