import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/)(?=\\*)(?:\\*)((?:\\1|[\\s\\S])*?)(?:\\*)\\1|(?=(\\/\\/)(.*))|<!--((?:(?!-->)[\\s\\S])*)-->";
final String string = "/*\n"
+ "something\n"
+ "*/\n\n"
+ "/* something */\n\n"
+ "/*\n"
+ " * // something\n"
+ " *\n"
+ " */\n\n"
+ "/*/something/*/\n\n"
+ " // teste\n\n"
+ "<!-- HTML Comment //-->\n"
+ "or\n"
+ "<!-- HTML Comment -->\n\n"
+ "<!-- HTML Comment\n"
+ "-->\n\n"
+ "<!--\n"
+ "HTML Comment\n"
+ " -->\n\n"
+ "// test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}