re = /(\/)(?=\*)(?:\*)((?:\1|[\s\S])*?)(?:\*)\1|(?=(\/\/)(.*))|<!--((?:(?!-->)[\s\S])*)-->/m
str = '/*
something
*/
/* something */
/*
* // something
*
*/
/*/something/*/
// teste
<!-- HTML Comment //-->
or
<!-- HTML Comment -->
<!-- HTML Comment
-->
<!--
HTML Comment
-->
// test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end