re = /(?<=expanded_url":")(?:(?!\/?").)+/m
str = 'expanded_url":"https://research.checkpoint.com/ramnits-network-proxy-servers/"
expanded_url":"https://research.checkpoint.com/ramnits-network-proxy-servers"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end