using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"import {[^}]*}.*(?='foo-bar').*";
string input = @"import React, { Component } from 'react'
import { withRouter } from 'react-router-dom'
import { connect } from 'react-redux'
import {
foo,
bar,
fooBar
} from 'foo-bar'
import { anotherThing } from 'another-module'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}