$re = '/import {[^}]*}.*(?=\'foo-bar\').*/';
$str = 'import React, { Component } from \'react\'
import { withRouter } from \'react-router-dom\'
import { connect } from \'react-redux\'
import {
foo,
bar,
fooBar
} from \'foo-bar\'
import { anotherThing } from \'another-module\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);