use strict;
my $str = 'import React, { Component } from \'react\'
import { withRouter } from \'react-router-dom\'
import { connect } from \'react-redux\'
import {
foo,
bar,
fooBar
} from \'foo-bar\'
import { anotherThing } from \'another-module\'';
my $regex = qr/import {[^}]*}.*(?='foo-bar').*/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}