using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*--.*\[[A-Z]+\]).*\[[A-Z]+\]";
string input = @"[GET] test
test [POST] test
test [POST] --test
test [GET] test --test [GET] test
test test
--[GET] test
test --[GET] test
test --test [GET] test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}