$re = '/^(?!.*--.*\[[A-Z]+\]).*\[[A-Z]+\]/m';
$str = '[GET] test
test [POST] test
test [POST] --test
test [GET] test --test [GET] test
test test
--[GET] test
test --[GET] test
test --test [GET] test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);