import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*--.*\\[[A-Z]+\\]).*\\[[A-Z]+\\]";
final String string = "[GET] test\n"
+ "test [POST] test\n"
+ "test [POST] --test\n"
+ "test [GET] test --test [GET] test\n\n"
+ "test test\n"
+ "--[GET] test\n"
+ "test --[GET] test\n"
+ "test --test [GET] test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}