#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^"the[^@]*fox[^@]*lazy[^@]*"$"
Local $sString = ""the quick brown fox " & @CRLF & _
"jumped over the lazy dog"" & @CRLF & _
"this string should not be selected" & @CRLF & _
"this string should not be selected" & @CRLF & _
""the quick brown fox " & @CRLF & _
"jumped over the lazy dog"" & @CRLF & _
""the quick brown fox jumped over the lazy dog"" & @CRLF & _
"this string should not be selected" & @CRLF & _
"the quick brown fox " & @CRLF & _
"jumped over the lazy dog" & @CRLF & _
"the quick brown fox jumped over the lazy dog" & @CRLF & _
"this string should not be selected"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")