re = /^"the[^@]*fox[^@]*lazy[^@]*"$/im
str = '"the quick brown fox
jumped over the lazy dog"
this string should not be selected
this string should not be selected
"the quick brown fox
jumped over the lazy dog"
"the quick brown fox jumped over the lazy dog"
this string should not be selected
the quick brown fox
jumped over the lazy dog
the quick brown fox jumped over the lazy dog
this string should not be selected'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end