use strict;
my $str = '"the quick brown fox
jumped over the lazy dog"
this string should not be selected
this string should not be selected
"the quick brown fox
jumped over the lazy dog"
"the quick brown fox jumped over the lazy dog"
this string should not be selected
the quick brown fox
jumped over the lazy dog
the quick brown fox jumped over the lazy dog
this string should not be selected';
my $regex = qr/^"the[^@]*fox[^@]*lazy[^@]*"$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}