package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\-[0-9]{2}(\-[\w\-]+)?$`)
var str = `Coverking_CSC_Neosupreme_1Row-F-150_Series-01-MASS`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}