$re = '/\-[0-9]{2}(\-[\w\-]+)?$/';
$str = 'Coverking_CSC_Neosupreme_1Row-F-150_Series-01-MASS';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);