const regex = /\-[0-9]{2}(\-[\w\-]+)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\-[0-9]{2}(\\-[\\w\\-]+)?$', '')
const str = `Coverking_CSC_Neosupreme_1Row-F-150_Series-01-MASS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}