using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s\s+";
string substitution = @" ";
string input = @" המחשבה בדבר המחשבה האמיתית היא מחתימה את הכל עבור מישהו ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}