re = /\s\s+/m
str = ' המחשבה בדבר המחשבה האמיתית היא מחתימה את הכל עבור מישהו '
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result