$re = '/\s\s+/m';
$str = ' המחשבה בדבר המחשבה האמיתית היא מחתימה את הכל עבור מישהו ';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;