package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+[\]|\w+[\,]\w+|\.|\?`)
var str = `"mary went to garden. where is mary? mary is carrying apple and milk. what mary is carrying? apple,milk" `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}