re = /\w+[\]|\w+[\,]\w+|\.|\?/
str = '"mary went to garden. where is mary? mary is carrying apple and milk. what mary is carrying? apple,milk" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end