package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Name\=\"Name\"[^\>]+\>(?<your_field>[^\<]+)`)
var str = `Details.Context = "dgfhgjj <Property Name="Name" VariantType="8">TRIMWorkgroup</Property>"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}