$re = '/Name\=\"Name\"[^\>]+\>(?<your_field>[^\<]+)/m';
$str = 'Details.Context = "dgfhgjj <Property Name="Name" VariantType="8">TRIMWorkgroup</Property>"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);