re = /Name\=\"Name\"[^\>]+\>(?<your_field>[^\<]+)/m
str = 'Details.Context = "dgfhgjj <Property Name="Name" VariantType="8">TRIMWorkgroup</Property>"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end