using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^BFPO ?\d{1,4}$";
string input = @"BFPO 1
BFPO 11
BFPO 111
BFPO 1111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}