$re = '/^BFPO ?\d{1,4}$/m';
$str = 'BFPO 1
BFPO 11
BFPO 111
BFPO 1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);