package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^BFPO ?\d{1,4}$`)
var str = `BFPO 1
BFPO 11
BFPO 111
BFPO 1111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}