import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:10ofthose\\.com|180post\\.net)$)[0-9]{2}[a-z]+\\.(?:net|com)$";
final String string = "99abc.com\n"
+ "78c.net\n"
+ "10ofthose.com\n"
+ "180post.net";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}