re = /^(?!(?:10ofthose\.com|180post\.net)$)[0-9]{2}[a-z]+\.(?:net|com)$/m
str = '99abc.com
78c.net
10ofthose.com
180post.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end