#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ims)(\d{2}\/\d{2}\/\d{4}),\s(\d(?:\d)?:\d{2})\s-\s([^:]*):\s(.*?)(?=\s*\d{2}\/|\$)"
Local $sString = "29/09/2018, 22:29 - מילה: העבירו בקבוצות שלכם לחברים, " & @CRLF & _
"הודעה מרופא *מאיכילוב* -" & @CRLF & _
"אני מחפש גבר בעל סוג דם AB+ בלבד," & @CRLF & _
"לתרומת דם, כדוריות לבנות, לילד הנלחם על חייו - לוקמיה. " & @CRLF & _
"הילד על הקצה ממש, " & @CRLF & _
"תפעילו את קשריכם החברתיים, " & @CRLF & _
"בואו ננסה לעשות טוב." & @CRLF & _
"תודה." & @CRLF & _
"ד"ר אילן. +972 54-440-3854" & @CRLF & _
"30/09/2018, 07:37 - ורד: ביום שלישי הקרוב .משעה 8-17 תחסם כניסה ג' ." & @CRLF & _
"" & @CRLF & _
"גם בתוך הדירות אסור יהיה להשאר." & @CRLF & _
"תודה על שיתוף הפעולה .נא ליידע את הדיירים ." & @CRLF & _
"חג שמח" & @CRLF & _
"26/08/2019, 20:28 - +972 54-477-1234: ערב טוב " & @CRLF & _
"לכל מי שטרם העביר לועד הבית את חלקו בתשלום לעורך הדין אנא עשו זאת ניתן להעביר מחר ." & @CRLF & _
"26/08/2019, 20:32 - יורם כהן(כניסה ב'): א.כמה התשלום הראשון . " & @CRLF & _
"ב. אפשר מחר בפגישה לקבל מצב חשבון של הועד" & @CRLF & _
"04/09/2019, 12:46 - +972 54-368-7925: שלחתי לכם מייל הבוקר" & @CRLF & _
"04/09/2019, 12:46 - +972 54-477-9495: מחר ההתקנה" & @CRLF & _
"04/09/2019, 12:47 - +972 54-477-4395: IMG-20190904-WA00353.jpg (file attached)" & @CRLF & _
"04/09/2019, 12:48 - +972 53-973-7566's security code changed. Tap for more info." & @CRLF & _
"04/09/2019, 12:49 - סיגל: תודה" & @CRLF & _
"04/09/2019, 13:20 - +972 54-480-9365: הי זה כולל מנעול רב בריח עם מפתחות חדשים?.." & @CRLF & _
"04/09/2019, 13:57 - +972 54-477-8795: אני מניח שכן" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")